elliptic curve

Elliptic-Curve Cryptography: elliptic curve cryptography

elliptic curve subjects:

elliptic curve RFCs (38)

Display RFCs as
  • RFC 10015: Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 9497: Oblivious Pseudorandom Functions (OPRFs) Using Prime-Order Groups

    Informational
  • RFC 9380: Hashing to Elliptic Curves

    Informational
  • RFC 8813: Clarifications for Elliptic Curve Cryptography Subject Public Key Information

    Proposed Standard
  • RFC 8734: Elliptic Curve Cryptography (ECC) Brainpool Curves for Transport Layer Security (TLS) Version 1.3

    Informational
  • RFC 8423: Reclassification of Suite B Documents to Historic Status

    Informational
  • RFC 8152: CBOR Object Signing and Encryption (COSE)

    Proposed Standard

    Obsoleted by RFC 9052, RFC 9053

  • RFC 8133: The Security Evaluated Standardized Password-Authenticated Key Exchange (SESPAKE) Protocol

    Informational
  • RFC 7859: Identity-Based Signatures for Mobile Ad Hoc Network (MANET) Routing Protocols

    Experimental
  • RFC 7836: Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012

    Informational
  • RFC 7748: Elliptic Curves for Security

    Informational
  • RFC 7664: Dragonfly Key Exchange

    Informational
  • RFC 7251: AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLS

    Informational
  • RFC 7027: Elliptic Curve Cryptography (ECC) Brainpool Curves for Transport Layer Security (TLS)

    Informational
  • RFC 6954: Using the Elliptic Curve Cryptography (ECC) Brainpool Curves for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Informational
  • RFC 6989: Additional Diffie-Hellman Tests for the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 6955: Diffie-Hellman Proof-of-Possession Algorithms

    Proposed Standard
  • RFC 6932: Brainpool Elliptic Curves for the Internet Key Exchange (IKE) Group Description Registry

    Informational
  • RFC 6637: Elliptic Curve Cryptography (ECC) in OpenPGP

    Proposed Standard

    Obsoleted by RFC 9580

  • RFC 6605: Elliptic Curve Digital Signature Algorithm (DSA) for DNSSEC

    Proposed Standard
  • RFC 6507: Elliptic Curve-Based Certificateless Signatures for Identity-Based Encryption (ECCSI)

    Informational
  • RFC 6379: Suite B Cryptographic Suites for IPsec

    Historic
  • RFC 6278: Use of Static-Static Elliptic Curve Diffie-Hellman Key Agreement in Cryptographic Message Syntax

    Informational
  • RFC 6090: Fundamental Elliptic Curve Cryptography Algorithms

    Informational
  • RFC 5903: Elliptic Curve Groups modulo a Prime (ECP Groups) for IKE and IKEv2

    Informational
  • RFC 5915: Elliptic Curve Private Key Structure

    Informational
  • RFC 5639: Elliptic Curve Cryptography (ECC) Brainpool Standard Curves and Curve Generation

    Informational
  • RFC 5753: Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)

    Informational
  • RFC 5656: Elliptic Curve Algorithm Integration in the Secure Shell Transport Layer

    Proposed Standard
  • RFC 5489: ECDHE_PSK Cipher Suites for Transport Layer Security (TLS)

    Informational
  • RFC 5480: Elliptic Curve Cryptography Subject Public Key Information

    Proposed Standard
  • RFC 5349: Elliptic Curve Cryptography (ECC) Support for Public Key Cryptography for Initial Authentication in Kerberos (PKINIT)

    Informational
  • RFC 5289: TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)

    Proposed Standard
  • RFC 5114: Additional Diffie-Hellman Groups for Use with IETF Standards

    Informational
  • RFC 5091: Identity-Based Cryptography Standard (IBCS) #1: Supersingular Curve Implementations of the BF and BB1 Cryptosystems

    Informational
  • RFC 4869: Suite B Cryptographic Suites for IPsec

    Historic

    Obsoleted by RFC 6379

  • RFC 4753: ECP Groups For IKE and IKEv2

    Informational

    Obsoleted by RFC 5903

  • RFC 3278: Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)

    Informational

    Obsoleted by RFC 5753

Subscribe to elliptic curve

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.