EAP

EAP (Extensible Authentication Protocol) and methods

EAP subjects:

EAP RFCs (59)

Display RFCs as
  • RFC 9966: Bootstrapped TLS Authentication with Proof of Knowledge

    Proposed Standard
  • RFC 9965: The eap.arpa. Domain and Extensible Authentication Protocol (EAP) Provisioning

    Proposed Standard
  • RFC 9930: Tunnel Extensible Authentication Protocol (TEAP) Version 1

    Proposed Standard
  • RFC 9820: Authentication Service Based on the Extensible Authentication Protocol (EAP) for Use with the Constrained Application Protocol (CoAP)

    Proposed Standard
  • RFC 9678: Forward Secrecy Extension to the Improved Extensible Authentication Protocol Method for Authentication and Key Agreement (EAP-AKA' FS)

    Proposed Standard
  • RFC 9427: TLS-Based Extensible Authentication Protocol (EAP) Types for Use with TLS 1.3

    Proposed Standard
  • RFC 9190: EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3

    Proposed Standard
  • RFC 9191: Handling Large Certificates and Long Certificate Chains in TLS-Based EAP Methods

    Informational
  • RFC 9140: Nimble Out-of-Band Authentication for EAP (EAP-NOOB)

    Proposed Standard
  • RFC 9048: Improved Extensible Authentication Protocol Method for 3GPP Mobile Network Authentication and Key Agreement (EAP-AKA')

    Proposed Standard
  • RFC 8146: Adding Support for Salted Password Databases to EAP-pwd

    Informational
  • RFC 7831: Application Bridging for Federated Access Beyond Web (ABFAB) Architecture

    Informational
  • RFC 7832: Application Bridging for Federated Access Beyond Web (ABFAB) Use Cases

    Informational
  • RFC 7833: A RADIUS Attribute, Binding, Profiles, Name Identifier Format, and Confirmation Methods for the Security Assertion Markup Language (SAML)

    Proposed Standard
  • RFC 7593: The eduroam Architecture for Network Roaming

    Informational
  • RFC 7458: Extensible Authentication Protocol (EAP) Attributes for Wi-Fi Integration with the Evolved Packet Core

    Informational
  • RFC 7170: Tunnel Extensible Authentication Protocol (TEAP) Version 1

    Proposed Standard

    Obsoleted by RFC 9930

  • RFC 7171: PT-EAP: Posture Transport (PT) Protocol for Extensible Authentication Protocol (EAP) Tunnel Methods

    Proposed Standard
  • RFC 7055: A GSS-API Mechanism for the Extensible Authentication Protocol

    Proposed Standard
  • RFC 7056: Name Attributes for the GSS-API Extensible Authentication Protocol (EAP) Mechanism

    Proposed Standard
  • RFC 7057: Update to the Extensible Authentication Protocol (EAP) Applicability Statement for Application Bridging for Federated Access Beyond Web (ABFAB)

    Proposed Standard
  • RFC 7029: Extensible Authentication Protocol (EAP) Mutual Cryptographic Binding

    Informational
  • RFC 6840: Clarifications and Implementation Notes for DNS Security (DNSSEC)

    Proposed Standard
  • RFC 6678: Requirements for a Tunnel-Based Extensible Authentication Protocol (EAP) Method

    Informational
  • RFC 6677: Channel-Binding Support for Extensible Authentication Protocol (EAP) Methods

    Proposed Standard
  • RFC 6345: Protocol for Carrying Authentication for Network Access (PANA) Relay Element

    Proposed Standard
  • RFC 6124: An EAP Authentication Method Based on the Encrypted Key Exchange (EKE) Protocol

    Informational
  • RFC 5998: An Extension for EAP-Only Authentication in IKEv2

    Proposed Standard
  • RFC 5931: Extensible Authentication Protocol (EAP) Authentication Using Only a Password

    Informational
  • RFC 5609: State Machines for the Protocol for Carrying Authentication for Network Access (PANA)

    Informational
  • RFC 5448: Improved Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA')

    Informational
  • RFC 5421: Basic Password Exchange within the Flexible Authentication via Secure Tunneling Extensible Authentication Protocol (EAP-FAST)

    Informational
  • RFC 5422: Dynamic Provisioning Using Flexible Authentication via Secure Tunneling Extensible Authentication Protocol (EAP-FAST)

    Informational
  • RFC 5433: Extensible Authentication Protocol - Generalized Pre-Shared Key (EAP-GPSK) Method

    Proposed Standard
  • RFC 5247: Extensible Authentication Protocol (EAP) Key Management Framework

    Proposed Standard
  • RFC 5281: Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)

    Informational
  • RFC 5191: Protocol for Carrying Authentication for Network Access (PANA)

    Proposed Standard
  • RFC 5216: The EAP-TLS Authentication Protocol

    Proposed Standard
  • RFC 5106: The Extensible Authentication Protocol-Internet Key Exchange Protocol version 2 (EAP-IKEv2) Method

    Experimental
  • RFC 5113: Network Discovery and Selection Problem

    Informational
  • RFC 4851: The Flexible Authentication via Secure Tunneling Extensible Authentication Protocol Method (EAP-FAST)

    Informational
  • RFC 4877: Mobile IPv6 Operation with IKEv2 and the Revised IPsec Architecture

    Proposed Standard
  • RFC 4793: The EAP Protected One-Time Password Protocol (EAP-POTP)

    Informational
  • RFC 4764: The EAP-PSK Protocol: A Pre-Shared Key Extensible Authentication Protocol (EAP) Method

    Experimental
  • RFC 4763: Extensible Authentication Protocol Method for Shared-secret Authentication and Key Establishment (EAP-SAKE)

    Informational
  • RFC 4746: Extensible Authentication Protocol (EAP) Password Authenticated Exchange

    Informational
  • RFC 4334: Certificate Extensions and Attributes Supporting Authentication in Point-to-Point Protocol (PPP) and Wireless Local Area Networks (WLAN)

    Proposed Standard
  • RFC 4284: Identity Selection Hints for the Extensible Authentication Protocol (EAP)

    Informational
  • RFC 4186: Extensible Authentication Protocol Method for Global System for Mobile Communications (GSM) Subscriber Identity Modules (EAP-SIM)

    Informational
  • RFC 4187: Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)

    Informational
  • RFC 4072: Diameter Extensible Authentication Protocol (EAP) Application

    Proposed Standard
  • RFC 4137: State Machines for Extensible Authentication Protocol (EAP) Peer and Authenticator

    Informational
  • RFC 4005: Diameter Network Access Server Application

    Proposed Standard

    Obsoleted by RFC 7155

  • RFC 4017: Extensible Authentication Protocol (EAP) Method Requirements for Wireless LANs

    Informational
  • RFC 3748: Extensible Authentication Protocol (EAP)

    Proposed Standard
  • RFC 3770: Certificate Extensions and Attributes Supporting Authentication in Point-to-Point Protocol (PPP) and Wireless Local Area Networks (WLAN)

    Proposed Standard

    Obsoleted by RFC 4334

  • RFC 3579: RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)

    Informational
  • RFC 2716: PPP EAP TLS Authentication Protocol

    Experimental

    Obsoleted by RFC 5216

  • RFC 2284: PPP Extensible Authentication Protocol (EAP)

    Proposed Standard

    Obsoleted by RFC 3748

Subscribe to EAP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.