DTLS

DTLS (Datagram Transport Layer Security): datagram TLS

DTLS RFCs (57)

Display RFCs as
  • RFC 10015: Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 9952: Application-Layer Protocol Negotiation (ALPN) ID for CoAP over DTLS

    Informational
  • RFC 9853: Return Routability Check for DTLS 1.2 and 1.3

    Proposed Standard
  • RFC 9847: IANA Registry Updates for TLS and DTLS

    Proposed Standard
  • RFC 9761: Manufacturer Usage Description (MUD) for TLS and DTLS Profiles for Internet of Things (IoT) Devices

    Proposed Standard
  • RFC 9662: Updates to the Cipher Suites in Secure Syslog

    Proposed Standard
  • RFC 9456: Updates to the TLS Transport Model for SNMP

    Proposed Standard
  • RFC 9345: Delegated Credentials for TLS and DTLS

    Proposed Standard
  • RFC 9443: Multiplexing Scheme Updates for QUIC

    Proposed Standard
  • RFC 9430: Extension of the Datagram Transport Layer Security (DTLS) Profile for Authentication and Authorization for Constrained Environments (ACE) to Transport Layer Security (TLS)

    Proposed Standard
  • RFC 9325: BCP 195: Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

    Best Current Practice
  • RFC 9202: Datagram Transport Layer Security (DTLS) Profile for Authentication and Authorization for Constrained Environments (ACE)

    Proposed Standard
  • RFC 9151: Commercial National Security Algorithm (CNSA) Suite Profile for TLS and DTLS 1.2 and 1.3

    Informational
  • RFC 9185: DTLS Tunnel between a Media Distributor and Key Distributor to Facilitate Key Exchange

    Informational
  • RFC 9147: The Datagram Transport Layer Security (DTLS) Protocol Version 1.3

    Proposed Standard
  • RFC 9146: Connection Identifier for DTLS 1.2

    Proposed Standard
  • RFC 9175: Constrained Application Protocol (CoAP): Echo, Request-Tag, and Token Processing

    Proposed Standard
  • RFC 9155: Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 8994: An Autonomic Control Plane (ACP)

    Proposed Standard
  • RFC 8841: Session Description Protocol (SDP) Offer/Answer Procedures for Stream Control Transmission Protocol (SCTP) over Datagram Transport Layer Security (DTLS) Transport

    Proposed Standard
  • RFC 8842: Session Description Protocol (SDP) Offer/Answer Considerations for Datagram Transport Layer Security (DTLS) and Transport Layer Security (TLS)

    Proposed Standard
  • RFC 8844: Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)

    Proposed Standard
  • RFC 8850: Controlling Multiple Streams for Telepresence (CLUE) Protocol Data Channel

    Experimental
  • RFC 8870: Encrypted Key Transport for DTLS and Secure RTP

    Proposed Standard
  • RFC 8968: Babel Routing Protocol over Datagram Transport Layer Security

    Proposed Standard
  • RFC 8442: ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for TLS 1.2 and DTLS 1.2

    Proposed Standard
  • RFC 8447: IANA Registry Updates for TLS and DTLS

    Proposed Standard
  • RFC 8310: Usage Profiles for DNS over TLS and DNS over DTLS

    Proposed Standard
  • RFC 8261: Datagram Transport Layer Security (DTLS) Encapsulation of SCTP Packets

    Proposed Standard
  • RFC 8269: The ARIA Algorithm and Its Use with the Secure Real-Time Transport Protocol (SRTP)

    Informational
  • RFC 8095: Services Provided by IETF Transport Protocols and Congestion Control Mechanisms

    Informational
  • RFC 8094: DNS over Datagram Transport Layer Security (DTLS)

    Experimental
  • RFC 7983: Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7925: Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of Things

    Proposed Standard
  • RFC 7905: ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)

    Proposed Standard
  • RFC 7879: DTLS-SRTP Handling in SIP Back-to-Back User Agents

    Proposed Standard
  • RFC 7585: Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)

    Experimental
  • RFC 7525: Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

    Best Current Practice

    Obsoleted by RFC 9325

  • RFC 7457: Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)

    Informational
  • RFC 7366: Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7360: Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUS

    Experimental
  • RFC 7350: Datagram Transport Layer Security (DTLS) as Transport for Session Traversal Utilities for NAT (STUN)

    Proposed Standard
  • RFC 7345: UDP Transport Layer (UDPTL) over Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 7250: Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 6520: Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat Extension

    Proposed Standard
  • RFC 6347: Datagram Transport Layer Security Version 1.2

    Proposed Standard

    Obsoleted by RFC 9147

  • RFC 6358: Additional Master Secret Inputs for TLS

    Experimental
  • RFC 6353: STD 78: Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)

    Internet Standard
  • RFC 6083: Datagram Transport Layer Security (DTLS) for Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 6084: General Internet Signaling Transport (GIST) over Stream Control Transmission Protocol (SCTP) and Datagram Transport Layer Security (DTLS)

    Experimental
  • RFC 6012: Datagram Transport Layer Security (DTLS) Transport Mapping for Syslog

    Proposed Standard
  • RFC 5953: Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)

    Proposed Standard

    Obsoleted by RFC 6353

  • RFC 5763: Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)

    Proposed Standard
  • RFC 5764: Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)

    Proposed Standard
  • RFC 5238: Datagram Transport Layer Security (DTLS) over the Datagram Congestion Control Protocol (DCCP)

    Proposed Standard
  • RFC 5027: Security Preconditions for Session Description Protocol (SDP) Media Streams

    Proposed Standard
  • RFC 4347: Datagram Transport Layer Security

    Historic

    Obsoleted by RFC 6347

Subscribe to DTLS

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.