COPS
COPS (Common Open Policy Service) and policy provisioning
Within this page
COPS RFCs (20)
RFC 4261: Common Open Policy Service (COPS) Over Transport Layer Security (TLS)
Proposed Standard- J. Walker
- A. Kulkarni
- December 2005
- IETF publication
- Operations and Management Area
Abstract
This document describes how to use Transport Layer Security (TLS) to secure Common Open Policy Service (COPS) connections over the Internet.
This document also updates RFC 2748 by modifying the contents of the Client-Accept message. [STANDARDS-TRACK]
Abstract
This document describes how to use Transport Layer Security (TLS) to secure Common Open Policy Service (COPS) connections over the Internet.
This document also updates RFC 2748 by modifying the contents of the Client-Accept message. [STANDARDS-TRACK]
RFC 4097: Middlebox Communications (MIDCOM) Protocol Evaluation
Informational- M. Barnes
- June 2005
- IETF publication
- Transport Area
Abstract
This document provides an evaluation of the applicability of SNMP (Simple Network Management Protocol), RSIP (Realm Specific Internet Protocol), Megaco, Diameter, and COPS (Common Open Policy Service) as the MIDCOM (Middlebox Communications) protocol. A summary of each of the proposed protocols against the MIDCOM requirements and the MIDCOM framework is provided. Compliancy of each of the protocols against each requirement is detailed. A conclusion summarizes how each of the protocols fares in the evaluation. This memo provides information for the Internet community.
Abstract
This document provides an evaluation of the applicability of SNMP (Simple Network Management Protocol), RSIP (Realm Specific Internet Protocol), Megaco, Diameter, and COPS (Common Open Policy Service) as the MIDCOM (Middlebox Communications) protocol. A summary of each of the proposed protocols against the MIDCOM requirements and the MIDCOM framework is provided. Compliancy of each of the protocols against each requirement is detailed. A conclusion summarizes how each of the protocols fares in the evaluation. This memo provides information for the Internet community.
RFC 3571: Framework Policy Information Base for Usage Feedback
Historic- D. Rawlins
- A. Kulkarni
- K. Ho Chan
- M. Bokaemper
- D. Dutt
- August 2003
- IETF publication
- Operations and Management Area
Abstract
This document describes a portion of the Policy Information Base (PIB) to control policy usage collection and reporting in a device. The provisioning classes specified here allow a Policy Decision Point (PDP) to select which policy objects should collect usage information, what information should be collected and when it should be reported. This PIB requires the presence of other PIBs (defined elsewhere) that provide the policy objects from which usage information is collected. This memo provides information for the Internet community.
Abstract
This document describes a portion of the Policy Information Base (PIB) to control policy usage collection and reporting in a device. The provisioning classes specified here allow a Policy Decision Point (PDP) to select which policy objects should collect usage information, what information should be collected and when it should be reported. This PIB requires the presence of other PIBs (defined elsewhere) that provide the policy objects from which usage information is collected. This memo provides information for the Internet community.
RFC 3520: Session Authorization Policy Element
Proposed Standard- L-N. Hamer
- B. Gage
- B. Kosinski
- H. Shieh
- April 2003
- IETF publication
- Operations and Management Area
Abstract
This document describes the representation of a session authorization policy element for supporting policy-based per-session authorization and admission control. The goal of session authorization is to allow the exchange of information between network elements in order to authorize the use of resources for a service and to co-ordinate actions between the signaling and transport planes. This document describes how a process on a system authorizes the reservation of resources by a host and then provides that host with a session authorization policy element which can be inserted into a resource reservation protocol (e.g., the Resource ReSerVation Protocol (RSVP) PATH message) to facilitate proper and secure reservation of those resources within the network. We describe the encoding of session authorization information as a policy element conforming to the format of a Policy Data object (RFC 2750) and provide details relating to operations, processing rules and error scenarios. [STANDARDS-TRACK]
Abstract
This document describes the representation of a session authorization policy element for supporting policy-based per-session authorization and admission control. The goal of session authorization is to allow the exchange of information between network elements in order to authorize the use of resources for a service and to co-ordinate actions between the signaling and transport planes. This document describes how a process on a system authorizes the reservation of resources by a host and then provides that host with a session authorization policy element which can be inserted into a resource reservation protocol (e.g., the Resource ReSerVation Protocol (RSVP) PATH message) to facilitate proper and secure reservation of those resources within the network. We describe the encoding of session authorization information as a policy element conforming to the format of a Policy Data object (RFC 2750) and provide details relating to operations, processing rules and error scenarios. [STANDARDS-TRACK]
RFC 3521: Framework for Session Set-up with Media Authorization
Informational- L-N. Hamer
- B. Gage
- H. Shieh
- April 2003
- IETF publication
- Operations and Management Area
Abstract
Establishing multimedia streams must take into account requirements for end-to-end QoS, authorization of network resource usage and accurate accounting for resources used. During session set up, policies may be enforced to ensure that the media streams being requested lie within the bounds of the service profile established for the requesting host. Similarly, when a host requests resources to provide a certain QoS for a packet flow, policies may be enforced to ensure that the required resources lie within the bounds of the resource profile established for the requesting host. To prevent fraud and to ensure accurate billing, this document describes various scenarios and mechanisms that provide the linkage required to verify that the resources being used to provide a requested QoS are in- line with the media streams requested (and authorized) for the session. This memo provides information for the Internet community.
Abstract
Establishing multimedia streams must take into account requirements for end-to-end QoS, authorization of network resource usage and accurate accounting for resources used. During session set up, policies may be enforced to ensure that the media streams being requested lie within the bounds of the service profile established for the requesting host. Similarly, when a host requests resources to provide a certain QoS for a packet flow, policies may be enforced to ensure that the required resources lie within the bounds of the resource profile established for the requesting host. To prevent fraud and to ensure accurate billing, this document describes various scenarios and mechanisms that provide the linkage required to verify that the resources being used to provide a requested QoS are in- line with the media streams requested (and authorized) for the session. This memo provides information for the Internet community.
RFC 3483: Framework for Policy Usage Feedback for Common Open Policy Service with Policy Provisioning (COPS-PR)
Informational- D. Rawlins
- A. Kulkarni
- M. Bokaemper
- K. Chan
- March 2003
- IETF publication
- Operations and Management Area
Abstract
Common Open Policy Services (COPS) Protocol (RFC 2748), defines the capability of reporting information to the Policy Decision Point (PDP). The types of report information are success, failure and accounting of an installed state. This document focuses on the COPS Report Type of Accounting and the necessary framework for the monitoring and reporting of usage feedback for an installed state. This memo provides information for the Internet community.
Abstract
Common Open Policy Services (COPS) Protocol (RFC 2748), defines the capability of reporting information to the Policy Decision Point (PDP). The types of report information are success, failure and accounting of an installed state. This document focuses on the COPS Report Type of Accounting and the necessary framework for the monitoring and reporting of usage feedback for an installed state. This memo provides information for the Internet community.
RFC 3318: Framework Policy Information Base
Historic- R. Sahita
- S. Hahn
- K. Chan
- K. McCloghrie
- March 2003
- IETF publication
- Operations and Management Area
Abstract
This document defines a set of PRovisioning Classes (PRCs) and textual conventions that are common to all clients that provision policy using Common Open Policy Service (COPS) protocol for Provisioning.
Structure of Policy Provisioning Information (SPPI) describes a structure for specifying policy information that can then be transmitted to a network device for the purpose of configuring policy at that device. The model underlying this structure is one of well-defined (PRCs) and instances of these classes (PRIs) residing in a virtual information store called the Policy Information Base (PIB).
One way to provision policy is by means of the (COPS) protocol with the extensions for provisioning. This protocol supports multiple clients, each of which may provision policy for a specific policy domain such as QoS, virtual private networks, or security.
As described in COPS usage for Policy Provisioning (COPS-PR), each client supports a non-overlapping and independent set of PIB modules. However, some PRovisioning Classes are common to all subject-categories (client-types) and need to be present in each.
Abstract
This document defines a set of PRovisioning Classes (PRCs) and textual conventions that are common to all clients that provision policy using Common Open Policy Service (COPS) protocol for Provisioning.
Structure of Policy Provisioning Information (SPPI) describes a structure for specifying policy information that can then be transmitted to a network device for the purpose of configuring policy at that device. The model underlying this structure is one of well-defined (PRCs) and instances of these classes (PRIs) residing in a virtual information store called the Policy Information Base (PIB).
One way to provision policy is by means of the (COPS) protocol with the extensions for provisioning. This protocol supports multiple clients, each of which may provision policy for a specific policy domain such as QoS, virtual private networks, or security.
As described in COPS usage for Policy Provisioning (COPS-PR), each client supports a non-overlapping and independent set of PIB modules. However, some PRovisioning Classes are common to all subject-categories (client-types) and need to be present in each.
RFC 3216: SMIng Objectives
Informational- C. Elliott
- D. Harrington
- J. Jason
- J. Schoenwaelder
- F. Strauss
- W. Weiss
- December 2001
- IETF publication
- Operations and Management Area
Abstract
This document describes the objectives for a new data definition language, suitable for the modeling of network management constructs, that can be directly mapped into SNMP and COPS-PR protocol operations. This memo provides information for the Internet community.
Abstract
This document describes the objectives for a new data definition language, suitable for the modeling of network management constructs, that can be directly mapped into SNMP and COPS-PR protocol operations. This memo provides information for the Internet community.
RFC 3181: Signaled Preemption Priority Policy Element
Proposed Standard- S. Herzog
- October 2001
- IETF publication
- Operations and Management Area
Abstract
This document describes a preemption priority policy element for use by signaled policy based admission protocols (such as the Resource ReSerVation Protocol (RSVP) and Common Open Policy Service (COPS). [STANDARDS-TRACK]
Abstract
This document describes a preemption priority policy element for use by signaled policy based admission protocols (such as the Resource ReSerVation Protocol (RSVP) and Common Open Policy Service (COPS). [STANDARDS-TRACK]
RFC 3182: Identity Representation for RSVP
Proposed Standard- S. Yadav
- R. Yavatkar
- R. Pabbati
- P. Ford
- T. Moore
- S. Herzog
- R. Hess
- October 2001
- IETF publication
- Operations and Management Area
Abstract
This document describes the representation of identity information in POLICY_DATA object for supporting policy based admission control in the Resource ReSerVation Protocol (RSVP). The goal of identity representation is to allow a process on a system to securely identify the owner and the application of the communicating process (e.g., user id) and convey this information in RSVP messages (PATH or RESV) in a secure manner. We describe the encoding of identities as RSVP policy element. We describe the processing rules to generate identity policy elements for multicast merged flows. [STANDARDS-TRACK]
Abstract
This document describes the representation of identity information in POLICY_DATA object for supporting policy based admission control in the Resource ReSerVation Protocol (RSVP). The goal of identity representation is to allow a process on a system to securely identify the owner and the application of the communicating process (e.g., user id) and convey this information in RSVP messages (PATH or RESV) in a secure manner. We describe the encoding of identities as RSVP policy element. We describe the processing rules to generate identity policy elements for multicast merged flows. [STANDARDS-TRACK]
RFC 3159: Structure of Policy Provisioning Information (SPPI)
Historic- K. McCloghrie
- M. Fine
- J. Seligson
- K. Chan
- S. Hahn
- R. Sahita
- A. Smith
- F. Reichmeyer
- August 2001
- IETF publication
- Operations and Management Area
Abstract
This document, the Structure of Policy Provisioning Information (SPPI), defines the adapted subset of SNMP's Structure of Management Information (SMI) used to write Policy Information Base (PIB) modules. [STANDARDS-TRACK]
Abstract
This document, the Structure of Policy Provisioning Information (SPPI), defines the adapted subset of SNMP's Structure of Management Information (SMI) used to write Policy Information Base (PIB) modules. [STANDARDS-TRACK]
RFC 3084: COPS Usage for Policy Provisioning (COPS-PR)
Historic- K. Chan
- J. Seligson
- D. Durham
- S. Gai
- K. McCloghrie
- S. Herzog
- F. Reichmeyer
- R. Yavatkar
- A. Smith
- March 2001
- IETF publication
- Operations and Management Area
Abstract
This document describes the use of the Common Open Policy Service (COPS) protocol for support of policy provisioning (COPS-PR). [STANDARDS-TRACK]
Abstract
This document describes the use of the Common Open Policy Service (COPS) protocol for support of policy provisioning (COPS-PR). [STANDARDS-TRACK]
RFC 2940: Definitions of Managed Objects for Common Open Policy Service (COPS) Protocol Clients
Proposed Standard- A. Smith
- D. Partain
- J. Seligson
- October 2000
- IETF publication
- Operations and Management Area
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP based internets. In particular it defines objects for managing a client of the Common Open Policy Service (COPS) protocol. [STANDARDS-TRACK]
Abstract
This memo defines a portion of the Management Information Base (MIB) for use with network management protocols in TCP/IP based internets. In particular it defines objects for managing a client of the Common Open Policy Service (COPS) protocol. [STANDARDS-TRACK]
RFC 2872: Application and Sub Application Identity Policy Element for Use with RSVP
Proposed Standard- Y. Bernet
- R. Pabbati
- June 2000
- IETF publication
- Operations and Management Area
Abstract
RSVP signaling messages typically include policy data objects, which in turn contain policy elements. Policy elements may describe user and/or application information, which may be used by RSVP aware network elements to apply appropriate policy decisions to a traffic flow. This memo details the usage of policy elements that provide application information. [STANDARDS-TRACK]
Abstract
RSVP signaling messages typically include policy data objects, which in turn contain policy elements. Policy elements may describe user and/or application information, which may be used by RSVP aware network elements to apply appropriate policy decisions to a traffic flow. This memo details the usage of policy elements that provide application information. [STANDARDS-TRACK]
RFC 2748: The COPS (Common Open Policy Service) Protocol
Proposed Standard- D. Durham
- J. Boyle
- R. Cohen
- S. Herzog
- R. Rajan
- A. Sastry
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This document describes a simple client/server model for supporting policy control over QoS signaling protocols. [STANDARDS-TRACK]
Abstract
This document describes a simple client/server model for supporting policy control over QoS signaling protocols. [STANDARDS-TRACK]
RFC 2749: COPS usage for RSVP
Proposed Standard- S. Herzog
- J. Boyle
- R. Cohen
- D. Durham
- R. Rajan
- A. Sastry
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This document describes usage directives for supporting COPS policy services in RSVP environments. [STANDARDS-TRACK]
Abstract
This document describes usage directives for supporting COPS policy services in RSVP environments. [STANDARDS-TRACK]
RFC 2750: RSVP Extensions for Policy Control
Proposed Standard- S. Herzog
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This memo presents a set of extensions for supporting generic policy based admission control in RSVP. [STANDARDS-TRACK]
Abstract
This memo presents a set of extensions for supporting generic policy based admission control in RSVP. [STANDARDS-TRACK]
RFC 2751: Signaled Preemption Priority Policy Element
Proposed Standard- S. Herzog
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This document describes a preemption priority policy element for use by signaled policy based admission protocols (such as RSVP and COPS). [STANDARDS-TRACK]
Obsoleted by RFC 3181
Abstract
This document describes a preemption priority policy element for use by signaled policy based admission protocols (such as RSVP and COPS). [STANDARDS-TRACK]
RFC 2752: Identity Representation for RSVP
Proposed Standard- S. Yadav
- R. Yavatkar
- R. Pabbati
- P. Ford
- T. Moore
- S. Herzog
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This document describes the representation of identity information in POLICY_DATA object for supporting policy based admission control in RSVP. [STANDARDS-TRACK]
Obsoleted by RFC 3182
Abstract
This document describes the representation of identity information in POLICY_DATA object for supporting policy based admission control in RSVP. [STANDARDS-TRACK]
RFC 2753: A Framework for Policy-based Admission Control
Informational- R. Yavatkar
- D. Pendarakis
- R. Guerin
- January 2000
- IETF publication
- Operations and Management Area
Abstract
This document is concerned with specifying a framework for providing policy-based control over admission control decisions. This memo provides information for the Internet community.
Abstract
This document is concerned with specifying a framework for providing policy-based control over admission control decisions. This memo provides information for the Internet community.
Subscribe to COPS
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.