congestion control

Congestion control and avoidance across transports

congestion control subjects:

congestion control RFCs (72)

Display RFCs as
  • RFC 9959: Careful Resume: Convergence of Congestion Control from Retained State

    Proposed Standard
  • RFC 9897: Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple Addresses

    Proposed Standard
  • RFC 9937: Proportional Rate Reduction (PRR)

    Proposed Standard
  • RFC 9840: rLEDBAT: Receiver-Driven Low Extra Delay Background Transport for TCP

    Experimental
  • RFC 9743: BCP 133: Specifying New Congestion Control Algorithms

    Best Current Practice
  • RFC 9406: HyStart++: Modified Slow Start for TCP

    Proposed Standard
  • RFC 9392: Sending RTP Control Protocol (RTCP) Feedback for Congestion Control in Interactive Multimedia Conferences

    Informational
  • RFC 9265: Forward Erasure Correction (FEC) Coding and Congestion Control in Transport

    Informational
  • RFC 9064: Considerations in the Development of a QoS Architecture for CCNx-Like Information-Centric Networking Protocols

    Informational
  • RFC 9002: QUIC Loss Detection and Congestion Control

    Proposed Standard
  • RFC 8985: The RACK-TLP Loss Detection Algorithm for TCP

    Proposed Standard
  • RFC 8888: RTP Control Protocol (RTCP) Feedback for Congestion Control

    Proposed Standard
  • RFC 8869: Evaluation Test Cases for Interactive Real-Time Media over Wireless Networks

    Informational
  • RFC 8699: Coupled Congestion Control for RTP Media

    Experimental
  • RFC 8680: Forward Error Correction (FEC) Framework Extension to Sliding Window Codes

    Proposed Standard
  • RFC 8681: Sliding Window Random Linear Code (RLC) Forward Erasure Correction (FEC) Schemes for FECFRAME

    Proposed Standard
  • RFC 8593: Video Traffic Models for RTP Congestion Control Evaluations

    Informational
  • RFC 8382: Shared Bottleneck Detection for Coupled Congestion Control for RTP Media

    Experimental
  • RFC 8298: Self-Clocked Rate Adaptation for Multimedia

    Experimental
  • RFC 8083: Multimedia Congestion Control: Circuit Breakers for Unicast RTP Sessions

    Proposed Standard
  • RFC 8084: BCP 208: Network Transport Circuit Breakers

    Best Current Practice
  • RFC 8041: Use Cases and Operational Experience with Multipath TCP

    Informational
  • RFC 7765: TCP and Stream Control Transmission Protocol (SCTP) RTO Restart

    Experimental
  • RFC 7295: Report from the IAB/IRTF Workshop on Congestion Control for Interactive Real-Time Communication

    Informational
  • RFC 6937: Proportional Rate Reduction for TCP

    Experimental

    Obsoleted by RFC 9937

  • RFC 6773: DCCP-UDP: A Datagram Congestion Control Protocol UDP Encapsulation for NAT Traversal

    Proposed Standard
  • RFC 6675: A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCP

    Proposed Standard
  • RFC 6633: Deprecation of ICMP Source Quench Messages

    Proposed Standard
  • RFC 6356: Coupled Congestion Control for Multipath Transport Protocols

    Experimental
  • RFC 6298: Computing TCP's Retransmission Timer

    Proposed Standard
  • RFC 6077: Open Research Issues in Internet Congestion Control

    Informational
  • RFC 6069: Making TCP More Robust to Long Connectivity Disruptions (TCP-LCD)

    Experimental
  • RFC 6057: Comcast's Protocol-Agnostic Congestion Management System

    Historic
  • RFC 5927: ICMP Attacks against TCP

    Informational
  • RFC 5762: RTP and the Datagram Congestion Control Protocol (DCCP)

    Proposed Standard
  • RFC 5783: Congestion Control in the RFC Series

    Informational
  • RFC 5690: Adding Acknowledgement Congestion Control to TCP

    Informational
  • RFC 5682: Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP

    Proposed Standard
  • RFC 5595: The Datagram Congestion Control Protocol (DCCP) Service Codes

    Proposed Standard
  • RFC 5596: Datagram Congestion Control Protocol (DCCP) Simultaneous-Open Technique to Facilitate NAT/Middlebox Traversal

    Proposed Standard
  • RFC 5597: BCP 150: Network Address Translation (NAT) Behavioral Requirements for the Datagram Congestion Control Protocol

    Best Current Practice
  • RFC 5681: TCP Congestion Control

    Draft Standard
  • RFC 5634: Quick-Start for the Datagram Congestion Control Protocol (DCCP)

    Experimental
  • RFC 5405: Unicast UDP Usage Guidelines for Application Designers

    Best Current Practice

    Obsoleted by RFC 8085

  • RFC 5238: Datagram Transport Layer Security (DTLS) over the Datagram Congestion Control Protocol (DCCP)

    Proposed Standard
  • RFC 5166: Metrics for the Evaluation of Congestion Control Mechanisms

    Informational
  • RFC 5033: Specifying New Congestion Control Algorithms

    Best Current Practice

    Obsoleted by RFC 9743

  • RFC 4654: TCP-Friendly Multicast Congestion Control (TFMCC): Protocol Specification

    Experimental
  • RFC 4336: Problem Statement for the Datagram Congestion Control Protocol (DCCP)

    Informational
  • RFC 4340: Datagram Congestion Control Protocol (DCCP)

    Proposed Standard
  • RFC 4341: Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion Control

    Proposed Standard
  • RFC 4222: BCP 112: Prioritized Treatment of Specific OSPF Version 2 Packets and Congestion Avoidance

    Best Current Practice
  • RFC 4138: Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP and the Stream Control Transmission Protocol (SCTP)

    Experimental
  • RFC 3738: Wave and Equation Based Rate Control (WEBRC) Building Block

    Experimental
  • RFC 3742: Limited Slow-Start for TCP with Large Congestion Windows

    Experimental
  • RFC 3714: IAB Concerns Regarding Congestion Control for Voice Traffic in the Internet

    Informational
  • RFC 3649: HighSpeed TCP for Large Congestion Windows

    Experimental
  • RFC 3522: The Eifel Detection Algorithm for TCP

    Experimental
  • RFC 3517: A Conservative Selective Acknowledgment (SACK)-based Loss Recovery Algorithm for TCP

    Proposed Standard

    Obsoleted by RFC 6675

  • RFC 3465: TCP Congestion Control with Appropriate Byte Counting (ABC)

    Experimental
  • RFC 3124: The Congestion Manager

    Proposed Standard
  • RFC 3042: Enhancing TCP's Loss Recovery Using Limited Transmit

    Proposed Standard
  • RFC 2988: Computing TCP's Retransmission Timer

    Proposed Standard

    Obsoleted by RFC 6298

  • RFC 2914: BCP 41: Congestion Control Principles

    Best Current Practice
  • RFC 2861: TCP Congestion Window Validation

    Historic

    Obsoleted by RFC 7661

  • RFC 2581: TCP Congestion Control

    Proposed Standard

    Obsoleted by RFC 5681

  • RFC 2309: Recommendations on Queue Management and Congestion Avoidance in the Internet

    Informational

    Obsoleted by RFC 7567

  • RFC 2001: TCP Slow Start, Congestion Avoidance, Fast Retransmit, and Fast Recovery Algorithms

    Proposed Standard

    Obsoleted by RFC 2581

  • RFC 1254: Gateway Congestion Control Survey

    Informational
  • RFC 1018: Some comments on SQuID

    Unknown
  • RFC 1016: Something a Host Could Do with Source Quench: The Source Quench Introduced Delay (SQuID)

    Unknown
  • RFC 896: Congestion Control in IP/TCP Internetworks

    Historic

    Obsoleted by RFC 7805

Subscribe to congestion control

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.