BGP

BGP (Border Gateway Protocol): protocol, policy, operations

BGP subjects:

BGP RFCs (239)

Display RFCs as
  • RFC 10039: Interconnecting EVPN and IPVPN Domains

    Proposed Standard
  • Proposed Standard
  • RFC 9871: BGP Color-Aware Routing (CAR)

    Experimental
  • Proposed Standard
  • RFC 9830: Advertising Segment Routing Policies in BGP

    Proposed Standard
  • RFC 9831: Segment Type Extensions for BGP Segment Routing (SR) Policy

    Experimental
  • RFC 9832: BGP Classful Transport Planes

    Experimental
  • Proposed Standard
  • Informational
  • RFC 9819: Argument Signaling for BGP Services in Segment Routing over IPv6 (SRv6)

    Proposed Standard
  • RFC 9829: Handling of Resource Public Key Infrastructure (RPKI) Certificate Revocation List (CRL) Number Extensions

    Proposed Standard
  • RFC 9793: BGP Extensions for Bit Index Explicit Replication (BIER)

    Proposed Standard
  • RFC 9723: BGP Colored Prefix Routing (CPR) for Services Based on Segment Routing over IPv6 (SRv6)

    Informational
  • RFC 9774: Deprecation of AS_SET and AS_CONFED_SET in BGP

    Proposed Standard
  • RFC 9746: BGP EVPN Multihoming Extensions for Split-Horizon Filtering

    Proposed Standard
  • RFC 9716: Mechanisms for MPLS Ping and Traceroute Procedures in Inter-Domain Segment Routing Networks

    Proposed Standard
  • RFC 9703: Label Switched Path (LSP) Ping/Traceroute for Segment Routing (SR) Egress Peer Engineering (EPE) Segment Identifiers (SIDs) with MPLS Data Plane

    Proposed Standard
  • RFC 9687: Border Gateway Protocol 4 (BGP-4) Send Hold Timer

    Proposed Standard
  • RFC 9582: A Profile for Route Origin Authorizations (ROAs)

    Proposed Standard
  • Proposed Standard
  • Proposed Standard
  • RFC 9494: Long-Lived Graceful Restart for BGP

    Proposed Standard
  • RFC 9384: A BGP Cease NOTIFICATION Subcode for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • Proposed Standard
  • RFC 9324: Policy Based on the Resource Public Key Infrastructure (RPKI) without Route Refresh

    Proposed Standard
  • RFC 9314: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • Proposed Standard
  • RFC 9252: BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)

    Proposed Standard
  • Proposed Standard
  • RFC 9234: Route Leak Prevention and Detection Using Roles in UPDATE and OPEN Messages

    Proposed Standard
  • RFC 9199: Considerations for Large Authoritative DNS Server Operators

    Informational
  • RFC 9160: Export of MPLS Segment Routing Label Type Information in IP Flow Information Export (IPFIX)

    Informational
  • RFC 9127: YANG Data Model for Bidirectional Forwarding Detection (BFD)

    Proposed Standard
  • RFC 9125: Gateway Auto-Discovery and Route Advertisement for Site Interconnection Using Segment Routing

    Proposed Standard
  • Proposed Standard
  • RFC 9087: Segment Routing Centralized BGP Egress Peer Engineering

    Informational
  • Proposed Standard
  • Proposed Standard
  • RFC 9072: Extended Optional Parameters Length for BGP OPEN Message

    Proposed Standard
  • RFC 9015: BGP Control Plane for the Network Service Header in Service Function Chaining

    Proposed Standard
  • Proposed Standard

    Obsoleted by RFC 9552

  • RFC 9012: The BGP Tunnel Encapsulation Attribute

    Proposed Standard
  • RFC 9013: OSPF Advertisement of Tunnel Encapsulations

    Proposed Standard
  • RFC 9003: Extended BGP Administrative Shutdown Communication

    Proposed Standard
  • RFC 8950: Advertising IPv4 Network Layer Reachability Information (NLRI) with an IPv6 Next Hop

    Proposed Standard
  • RFC 8893: Resource Public Key Infrastructure (RPKI) Origin Validation for BGP Export

    Proposed Standard
  • RFC 8810: Revision to Capability Codes Registration Procedures

    Proposed Standard
  • Proposed Standard
  • RFC 8704: BCP 84: Enhanced Feasible-Path Unicast Reverse Path Forwarding

    Best Current Practice
  • RFC 8669: Segment Routing Prefix Segment Identifier Extensions for BGP

    Proposed Standard
  • RFC 8670: BGP Prefix Segment in Large-Scale Data Centers

    Informational
  • RFC 8654: Extended Message Support for BGP

    Proposed Standard
  • RFC 8614: Updated Processing of Control Flags for BGP Virtual Private LAN Service (VPLS)

    Proposed Standard
  • Proposed Standard
  • RFC 8538: Notification Message Support for BGP Graceful Restart

    Proposed Standard
  • RFC 8522: Looking Glass Command Set

    Informational
  • RFC 8502: L2L3 VPN Multicast MIB

    Proposed Standard
  • RFC 8503: BGP/MPLS Layer 3 VPN Multicast Management Information Base

    Proposed Standard
  • RFC 8476: Signaling Maximum SID Depth (MSD) Using OSPF

    Proposed Standard
  • RFC 8491: Signaling Maximum SID Depth (MSD) Using IS-IS

    Proposed Standard
  • RFC 8481: Clarifications to BGP Origin Validation Based on Resource Public Key Infrastructure (RPKI)

    Proposed Standard
  • RFC 8395: Extensions to BGP-Signaled Pseudowires to Support Flow-Aware Transport Labels

    Proposed Standard
  • RFC 8388: Usage and Applicability of BGP MPLS-Based Ethernet VPN

    Informational
  • RFC 8326: Graceful BGP Session Shutdown

    Proposed Standard
  • RFC 8327: BCP 214: Mitigating the Negative Impact of Maintenance through BGP Session Culling

    Best Current Practice
  • RFC 8313: BCP 213: Use of Multicast across Inter-domain Peering Points

    Best Current Practice
  • RFC 8277: Using BGP to Bind MPLS Labels to Address Prefixes

    Proposed Standard
  • RFC 8205: BGPsec Protocol Specification

    Proposed Standard
  • RFC 8207: BCP 211: BGPsec Operational Considerations

    Best Current Practice
  • RFC 8211: Adverse Actions by a Certification Authority (CA) or Repository Manager in the Resource Public Key Infrastructure (RPKI)

    Informational
  • RFC 8203: BGP Administrative Shutdown Communication

    Proposed Standard

    Obsoleted by RFC 9003

  • RFC 8212: Default External BGP (EBGP) Route Propagation Behavior without Policies

    Proposed Standard
  • RFC 8050: Multi-Threaded Routing Toolkit (MRT) Routing Information Export Format with BGP Additional Path Extensions

    Proposed Standard
  • RFC 8097: BGP Prefix Origin Validation State Extended Community

    Proposed Standard
  • RFC 8093: Deprecation of BGP Path Attribute Values 30, 31, 129, 241, 242, and 243

    Proposed Standard
  • RFC 7999: BLACKHOLE Community

    Informational
  • RFC 7964: Solutions for BGP Persistent Route Oscillation

    Proposed Standard
  • RFC 7938: Use of BGP for Routing in Large-Scale Data Centers

    Informational
  • RFC 7911: Advertisement of Multiple Paths in BGP

    Proposed Standard
  • RFC 7899: Multicast VPN State Damping

    Proposed Standard
  • RFC 7900: Extranet Multicast in BGP/IP MPLS VPNs

    Proposed Standard
  • RFC 7908: Problem Definition and Classification of BGP Route Leaks

    Informational
  • RFC 7747: Basic BGP Convergence Benchmarking Methodology for Data-Plane Convergence

    Informational
  • RFC 7789: Impact of BGP Filtering on Inter-Domain Routing Policies

    Informational
  • RFC 7814: Virtual Subnet: A BGP/MPLS IP VPN-Based Subnet Extension Solution

    Informational
  • Proposed Standard

    Obsoleted by RFC 9552

  • RFC 7730: Resource Public Key Infrastructure (RPKI) Trust Anchor Locator

    Proposed Standard

    Obsoleted by RFC 8630

  • RFC 7682: Considerations for Internet Routing Registries (IRRs) and Routing Policy Configuration

    Informational
  • RFC 7716: Global Table Multicast with BGP Multicast VPN (BGP-MVPN) Procedures

    Proposed Standard
  • RFC 7705: Autonomous System Migration Mechanisms and Their Effects on the BGP AS_PATH Attribute

    Proposed Standard
  • RFC 7611: BGP ACCEPT_OWN Community Attribute

    Proposed Standard
  • RFC 7606: Revised Error Handling for BGP UPDATE Messages

    Proposed Standard
  • RFC 7607: Codification of AS 0 Processing

    Proposed Standard
  • RFC 7543: Covering Prefixes Outbound Route Filter for BGP-4

    Proposed Standard
  • RFC 7432: BGP MPLS-Based Ethernet VPN

    Proposed Standard
  • RFC 7454: BCP 194: BGP Operations and Security

    Best Current Practice
  • RFC 7447: Deprecation of BGP Entropy Label Capability Attribute

    Proposed Standard
  • RFC 7441: Encoding Multipoint LDP (mLDP) Forwarding Equivalence Classes (FECs) in the NLRI of BGP MCAST-VPN Routes

    Proposed Standard
  • RFC 7353: Security Requirements for BGP Path Validation

    Informational
  • RFC 7311: The Accumulated IGP Metric Attribute for BGP

    Proposed Standard
  • RFC 7313: Enhanced Route Refresh Capability for BGP-4

    Proposed Standard
  • RFC 7300: BCP 6: Reservation of Last Autonomous System (AS) Numbers

    Best Current Practice
  • RFC 7289: Carrier-Grade NAT (CGN) Deployment with BGP/MPLS IP VPNs

    Informational
  • RFC 7196: Making Route Flap Damping Usable

    Proposed Standard
  • RFC 7132: Threat Model for BGP Path Security

    Informational
  • RFC 7024: Virtual Hub-and-Spoke in BGP/MPLS VPNs

    Proposed Standard
  • RFC 6996: BCP 6: Autonomous System (AS) Reservation for Private Use

    Best Current Practice
  • RFC 6952: Analysis of BGP, LDP, PCEP, and MSDP Issues According to the Keying and Authentication for Routing Protocols (KARP) Design Guide

    Informational
  • RFC 6938: Deprecation of BGP Path Attributes: DPA, ADVERTISER, and RCID_PATH / CLUSTER_ID

    Proposed Standard
  • RFC 6916: BCP 182: Algorithm Agility Procedure for the Resource Public Key Infrastructure (RPKI)

    Best Current Practice
  • RFC 6907: Use Cases and Interpretations of Resource Public Key Infrastructure (RPKI) Objects for Issuers and Relying Parties

    Informational
  • RFC 6811: BGP Prefix Origin Validation

    Proposed Standard
  • RFC 6793: BGP Support for Four-Octet Autonomous System (AS) Number Space

    Proposed Standard
  • RFC 6774: Distribution of Diverse BGP Paths

    Informational
  • RFC 6769: Simple Virtual Aggregation (S-VA)

    Informational
  • RFC 6752: Issues with Private IP Addressing in the Internet

    Informational
  • RFC 6565: OSPFv3 as a Provider Edge to Customer Edge (PE-CE) Routing Protocol

    Proposed Standard
  • RFC 6624: Layer 2 Virtual Private Networks Using BGP for Auto-Discovery and Signaling

    Informational
  • RFC 6608: Subcodes for BGP Finite State Machine Error

    Proposed Standard
  • RFC 6513: Multicast in MPLS/BGP IP VPNs

    Proposed Standard
  • RFC 6514: BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNs

    Proposed Standard
  • RFC 6515: IPv4 and IPv6 Infrastructure Addresses in BGP Updates for Multicast VPN

    Proposed Standard
  • RFC 6517: Mandatory Features in a Layer 3 Multicast BGP/MPLS VPN Solution

    Informational
  • RFC 6480: An Infrastructure to Support Secure Internet Routing

    Informational
  • RFC 6482: A Profile for Route Origin Authorizations (ROAs)

    Proposed Standard

    Obsoleted by RFC 9582

  • RFC 6483: Validation of Route Origination Using the Resource Certificate Public Key Infrastructure (PKI) and Route Origin Authorizations (ROAs)

    Informational
  • RFC 6472: BCP 172: Recommendation for Not Using AS_SET and AS_CONFED_SET in BGP

    Best Current Practice

    Obsoleted by RFC 9774

  • RFC 6441: BCP 171: Time to Remove Filters for Previously Unallocated IPv4 /8s

    Best Current Practice
  • RFC 6396: Multi-Threaded Routing Toolkit (MRT) Routing Information Export Format

    Proposed Standard
  • RFC 6397: Multi-Threaded Routing Toolkit (MRT) Border Gateway Protocol (BGP) Routing Information Export Format with Geo-Location Extensions

    Proposed Standard
  • RFC 6382: BCP 169: Unique Origin Autonomous System Numbers (ASNs) per Node for Globally Anycasted Services

    Best Current Practice
  • RFC 6368: Internal BGP as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 6286: Autonomous-System-Wide Unique BGP Identifier for BGP-4

    Proposed Standard
  • RFC 6198: Requirements for the Graceful Shutdown of BGP Sessions

    Informational
  • RFC 6037: Cisco Systems' Solution for Multicast in BGP/MPLS IP VPNs

    Historic
  • RFC 5961: Improving TCP's Robustness to Blind In-Window Attacks

    Proposed Standard
  • RFC 5824: Requirements for Supporting Customer Resource ReSerVation Protocol (RSVP) and RSVP Traffic Engineering (RSVP-TE) over a BGP/MPLS IP-VPN

    Informational
  • RFC 5747: 4over6 Transit Solution Using IP Encapsulation and MP-BGP Extensions

    Experimental
  • RFC 5640: Load-Balancing for Mesh Softwires

    Proposed Standard
  • RFC 5566: BGP IPsec Tunnel Encapsulation Attribute

    Proposed Standard

    Obsoleted by RFC 9012

  • RFC 5543: BGP Traffic Engineering Attribute

    Proposed Standard
  • RFC 5549: Advertising IPv4 Network Layer Reachability Information with an IPv6 Next Hop

    Proposed Standard

    Obsoleted by RFC 8950

  • RFC 5512: The BGP Encapsulation Subsequent Address Family Identifier (SAFI) and the BGP Tunnel Encapsulation Attribute

    Proposed Standard

    Obsoleted by RFC 9012

  • RFC 5492: Capabilities Advertisement with BGP-4

    Draft Standard
  • RFC 5398: Autonomous System (AS) Number Reservation for Documentation Use

    Informational
  • RFC 5396: Textual Representation of Autonomous System (AS) Numbers

    Proposed Standard
  • RFC 5291: Outbound Route Filtering Capability for BGP-4

    Proposed Standard
  • RFC 5292: Address-Prefix-Based Outbound Route Filter for BGP-4

    Proposed Standard
  • RFC 5195: BGP-Based Auto-Discovery for Layer-1 VPNs

    Proposed Standard
  • RFC 5160: Considerations of Provider-to-Provider Agreements for Internet-Scale Quality of Service (QoS)

    Informational
  • RFC 5123: Considerations in Validating the Path in BGP

    Informational
  • RFC 5004: Avoid BGP Best Path Transitions from One External to Another

    Proposed Standard
  • RFC 5065: Autonomous System Confederations for BGP

    Draft Standard
  • RFC 4893: BGP Support for Four-octet AS Number Space

    Proposed Standard

    Obsoleted by RFC 6793

  • RFC 4808: Key Change Strategies for TCP-MD5

    Informational
  • RFC 4798: Connecting IPv6 Islands over IPv4 MPLS Using IPv6 Provider Edge Routers (6PE)

    Proposed Standard
  • RFC 4797: Use of Provider Edge to Provider Edge (PE-PE) Generic Routing Encapsulation (GRE) or IP in BGP/MPLS IP Virtual Private Networks

    Informational
  • RFC 4781: Graceful Restart Mechanism for BGP with MPLS

    Proposed Standard
  • RFC 4724: Graceful Restart Mechanism for BGP

    Proposed Standard
  • RFC 4760: Multiprotocol Extensions for BGP-4

    Draft Standard
  • RFC 4761: Virtual Private LAN Service (VPLS) Using BGP for Auto-Discovery and Signaling

    Proposed Standard
  • RFC 4786: BCP 126: Operation of Anycast Services

    Best Current Practice
  • RFC 4684: Constrained Route Distribution for Border Gateway Protocol/MultiProtocol Label Switching (BGP/MPLS) Internet Protocol (IP) Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4659: BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPN

    Proposed Standard
  • RFC 4632: BCP 122: Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan

    Best Current Practice
  • Proposed Standard
  • RFC 4577: OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4486: Subcodes for BGP Cease Notification Message

    Proposed Standard
  • RFC 4451: BGP MULTI_EXIT_DISC (MED) Considerations

    Informational
  • RFC 4382: MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base

    Proposed Standard
  • RFC 4364: BGP/MPLS IP Virtual Private Networks (VPNs)

    Proposed Standard
  • RFC 4365: Applicability Statement for BGP/MPLS IP Virtual Private Networks (VPNs)

    Informational
  • RFC 4381: Analysis of the Security of BGP/MPLS IP Virtual Private Networks (VPNs)

    Informational
  • RFC 4271: A Border Gateway Protocol 4 (BGP-4)

    Draft Standard
  • RFC 4272: BGP Security Vulnerabilities Analysis

    Informational
  • RFC 4273: Definitions of Managed Objects for BGP-4

    Proposed Standard
  • RFC 4274: BGP-4 Protocol Analysis

    Informational
  • RFC 4275: BGP-4 MIB Implementation Survey

    Informational
  • RFC 4276: BGP-4 Implementation Report

    Informational
  • RFC 4277: Experience with the BGP-4 Protocol

    Informational
  • RFC 4278: Standards Maturity Variance Regarding the TCP MD5 Signature Option (RFC 2385) and the BGP-4 Specification

    Informational
  • RFC 4264: BGP Wedgies

    Informational
  • RFC 4223: Reclassification of RFC 1863 to Historic

    Informational
  • RFC 4085: BCP 105: Embedding Globally-Routable Internet Addresses Considered Harmful

    Best Current Practice
  • RFC 4098: Terminology for Benchmarking BGP Device Convergence in the Control Plane

    Informational
  • RFC 3882: Configuring BGP to Block Denial-of-Service Attacks

    Informational
  • RFC 3913: Border Gateway Multicast Protocol (BGMP): Protocol Specification

    Historic
  • RFC 3765: NOPEER Community for Border Gateway Protocol (BGP) Route Scope Control

    Informational
  • RFC 3562: Key Management Considerations for the TCP MD5 Signature Option

    Informational
  • RFC 3392: Capabilities Advertisement with BGP-4

    Draft Standard

    Obsoleted by RFC 5492

  • RFC 3345: Border Gateway Protocol (BGP) Persistent Route Oscillation Condition

    Informational
  • RFC 3219: Telephony Routing over IP (TRIP)

    Proposed Standard
  • RFC 3221: Commentary on Inter-Domain Routing in the Internet

    Informational
  • RFC 3166: Request to Move RFC 1403 to Historic Status

    Informational
  • RFC 3167: Request to Move RFC 1745 to Historic Status

    Informational
  • RFC 3107: Carrying Label Information in BGP-4

    Proposed Standard

    Obsoleted by RFC 8277

  • RFC 3065: Autonomous System Confederations for BGP

    Proposed Standard

    Obsoleted by RFC 5065

  • RFC 2918: Route Refresh Capability for BGP-4

    Proposed Standard
  • RFC 2858: Multiprotocol Extensions for BGP-4

    Proposed Standard

    Obsoleted by RFC 4760

  • RFC 2842: Capabilities Advertisement with BGP-4

    Proposed Standard

    Obsoleted by RFC 3392

  • RFC 2769: Routing Policy System Replication

    Proposed Standard
  • RFC 2754: RPS IANA Issues

    Historic

    Obsoleted by RFC 6254

  • RFC 2725: Routing Policy System Security

    Proposed Standard
  • RFC 2726: PGP Authentication for RIPE Database Updates

    Proposed Standard
  • RFC 2650: Using RPSL in Practice

    Informational
  • RFC 2622: Routing Policy Specification Language (RPSL)

    Proposed Standard
  • RFC 2545: Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing

    Proposed Standard
  • RFC 2547: BGP/MPLS VPNs

    Informational

    Obsoleted by RFC 4364

  • RFC 2519: A Framework for Inter-Domain Route Aggregation

    Informational
  • RFC 2439: BGP Route Flap Damping

    Proposed Standard
  • RFC 2385: Protection of BGP Sessions via the TCP MD5 Signature Option

    Proposed Standard

    Obsoleted by RFC 5925

  • RFC 2283: Multiprotocol Extensions for BGP-4

    Proposed Standard

    Obsoleted by RFC 2858

  • RFC 2270: Using a Dedicated AS for Sites Homed to a Single Provider

    Informational
  • RFC 2280: Routing Policy Specification Language (RPSL)

    Proposed Standard

    Obsoleted by RFC 2622

  • RFC 2042: Registering New BGP Attribute Types

    Informational
  • RFC 1965: Autonomous System Confederations for BGP

    Experimental

    Obsoleted by RFC 3065

  • RFC 1930: BCP 6: Guidelines for creation, selection, and registration of an Autonomous System (AS)

    Best Current Practice
  • RFC 1771: A Border Gateway Protocol 4 (BGP-4)

    Draft Standard

    Obsoleted by RFC 4271

  • RFC 1772: Application of the Border Gateway Protocol in the Internet

    Draft Standard
  • RFC 1773: Experience with the BGP-4 protocol

    Informational
  • RFC 1774: BGP-4 Protocol Analysis

    Informational
  • RFC 1745: BGP4/IDRP for IP---OSPF Interaction

    Historic
  • RFC 1654: A Border Gateway Protocol 4 (BGP-4)

    Proposed Standard

    Obsoleted by RFC 1771

  • RFC 1655: Application of the Border Gateway Protocol in the Internet

    Proposed Standard

    Obsoleted by RFC 1772

  • RFC 1656: BGP-4 Protocol Document Roadmap and Implementation Experience

    Informational

    Obsoleted by RFC 1773

  • RFC 1657: Definitions of Managed Objects for the Fourth Version of the Border Gateway Protocol (BGP-4) using SMIv2

    Draft Standard

    Obsoleted by RFC 4273

  • RFC 1482: Aggregation Support in the NSFNET Policy-Based Routing Database

    Historic
  • RFC 1397: Default Route Advertisement In BGP2 and BGP3 Version of The Border Gateway Protocol

    Historic
  • RFC 1403: BGP OSPF Interaction

    Historic
  • RFC 1364: BGP OSPF Interaction

    Proposed Standard

    Obsoleted by RFC 1403

  • RFC 1322: A Unified Approach to Inter-Domain Routing

    Informational
  • RFC 1265: BGP Protocol Analysis

    Informational
  • RFC 1266: Experience with the BGP Protocol

    Informational
  • RFC 1267: Border Gateway Protocol 3 (BGP-3)

    Historic
  • RFC 1268: Application of the Border Gateway Protocol in the Internet

    Historic

    Obsoleted by RFC 1655

  • RFC 1269: Definitions of Managed Objects for the Border Gateway Protocol: Version 3

    Proposed Standard

    Obsoleted by RFC 4273

  • RFC 1163: Border Gateway Protocol (BGP)

    Historic

    Obsoleted by RFC 1267

  • RFC 1164: Application of the Border Gateway Protocol in the Internet

    Historic

    Obsoleted by RFC 1268

  • RFC 1105: Border Gateway Protocol (BGP)

    Experimental

    Obsoleted by RFC 1163

Subscribe to BGP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.