authentication

Authentication of users, hosts and messages across protocols

authentication subjects:

authentication RFCs (147)

Display RFCs as
  • RFC 9918: Updates to Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

    Proposed Standard
  • RFC 9985: Optimizing Bidirectional Forwarding Detection (BFD) Authentication

    Experimental
  • RFC 9986: Meticulous Keyed ISAAC for Bidirectional Forwarding Detection (BFD) Optimized Authentication

    Experimental
  • RFC 9932: Mutually Authenticating TLS in the Context of Federations

    Informational
  • Proposed Standard
  • RFC 9770: Notification of Revoked Access Tokens in the Authentication and Authorization for Constrained Environments (ACE) Framework

    Proposed Standard
  • RFC 9729: The Concealed HTTP Authentication Scheme

    Proposed Standard
  • RFC 9594: Key Provisioning for Group Communication Using Authentication and Authorization for Constrained Environments (ACE)

    Proposed Standard
  • RFC 9593: Announcing Supported Authentication Methods in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 9615: Automatic DNSSEC Bootstrapping Using Authenticated Signals from the Zone's Operator

    Proposed Standard
  • RFC 9575: DRIP Entity Tag (DET) Authentication Formats and Protocols for Broadcast Remote Identification (RID)

    Proposed Standard
  • RFC 9577: The Privacy Pass HTTP Authentication Scheme

    Proposed Standard
  • RFC 9560: Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID Connect

    Proposed Standard
  • RFC 9467: Relaxed Packet Counter Verification for Babel MAC Authentication

    Proposed Standard
  • RFC 9431: Message Queuing Telemetry Transport (MQTT) and Transport Layer Security (TLS) Profile of Authentication and Authorization for Constrained Environments (ACE) Framework

    Proposed Standard
  • RFC 9261: Exported Authenticators in TLS

    Proposed Standard
  • RFC 9235: TCP Authentication Option (TCP-AO) Test Vectors

    Informational
  • RFC 9150: TLS 1.3 Authentication and Integrity-Only Cipher Suites

    Informational
  • RFC 8967: MAC Authentication for the Babel Routing Protocol

    Proposed Standard
  • RFC 8945: STD 93: Secret Key Transaction Authentication for DNS (TSIG)

    Internet Standard
  • RFC 8902: TLS Authentication Using Intelligent Transport System (ITS) Certificates

    Experimental
  • RFC 8773: TLS 1.3 Extension for Certificate-Based Authentication with an External Pre-Shared Key

    Experimental

    Obsoleted by RFC 9973

  • RFC 8760: The Session Initiation Protocol (SIP) Digest Access Authentication Scheme

    Proposed Standard
  • RFC 8221: Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard
  • RFC 7929: DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGP

    Experimental
  • RFC 7860: HMAC-SHA-2 Authentication Protocols in User-Based Security Model (USM) for SNMPv3

    Proposed Standard
  • RFC 7773: Authentication Context Certificate Extension

    Proposed Standard
  • RFC 7744: Use Cases for Authentication and Authorization in Constrained Environments

    Informational
  • RFC 7630: HMAC-SHA-2 Authentication Protocols in the User-based Security Model (USM) for SNMPv3

    Proposed Standard

    Obsoleted by RFC 7860

  • RFC 7671: The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational Guidance

    Proposed Standard
  • RFC 7672: SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)

    Proposed Standard
  • RFC 7673: Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV Records

    Proposed Standard
  • RFC 7615: HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields

    Proposed Standard

    Obsoleted by RFC 9110

  • RFC 7652: Port Control Protocol (PCP) Authentication Mechanism

    Proposed Standard
  • RFC 7645: The Keying and Authentication for Routing Protocol (KARP) IS-IS Security Analysis

    Informational
  • RFC 7619: The NULL Authentication Method in the Internet Key Exchange Protocol Version 2 (IKEv2)

    Proposed Standard
  • RFC 7589: Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication

    Proposed Standard
  • RFC 7492: Analysis of Bidirectional Forwarding Detection (BFD) Security According to the Keying and Authentication for Routing Protocols (KARP) Design Guidelines

    Informational
  • RFC 7427: Signature Authentication in the Internet Key Exchange Version 2 (IKEv2)

    Proposed Standard
  • RFC 7376: Problems with Session Traversal Utilities for NAT (STUN) Long-Term Authentication for Traversal Using Relays around NAT (TURN)

    Informational
  • RFC 7372: Email Authentication Status Codes

    Proposed Standard
  • RFC 7321: Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard

    Obsoleted by RFC 8221

  • RFC 7349: LDP Hello Cryptographic Authentication

    Proposed Standard
  • RFC 7298: Babel Hashed Message Authentication Code (HMAC) Cryptographic Authentication

    Experimental

    Obsoleted by RFC 8967

  • RFC 7235: Hypertext Transfer Protocol (HTTP/1.1): Authentication

    Proposed Standard

    Obsoleted by RFC 9110

  • RFC 7236: Initial Hypertext Transfer Protocol (HTTP) Authentication Scheme Registrations

    Informational
  • RFC 7253: The OCB Authenticated-Encryption Algorithm

    Informational
  • RFC 7218: Adding Acronyms to Simplify Conversations about DNS-Based Authentication of Named Entities (DANE)

    Proposed Standard
  • RFC 7166: Supporting Authentication Trailer for OSPFv3

    Proposed Standard
  • RFC 7129: Authenticated Denial of Existence in the DNS

    Informational
  • RFC 6978: A TCP Authentication Option Extension for NAT Traversal

    Experimental
  • RFC 6952: Analysis of BGP, LDP, PCEP, and MSDP Issues According to the Keying and Authentication for Routing Protocols (KARP) Design Guide

    Informational
  • RFC 6862: Keying and Authentication for Routing Protocols (KARP) Overview, Threats, and Requirements

    Informational
  • RFC 6863: Analysis of OSPF Security According to the Keying and Authentication for Routing Protocols (KARP) Design Guide

    Informational
  • RFC 6698: The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSA

    Proposed Standard
  • RFC 6704: Forcerenew Nonce Authentication

    Proposed Standard
  • RFC 6631: Password Authenticated Connection Establishment with the Internet Key Exchange Protocol version 2 (IKEv2)

    Experimental
  • RFC 6617: Secure Pre-Shared Key (PSK) Authentication for the Internet Key Exchange Protocol (IKE)

    Experimental
  • RFC 6584: Simple Authentication Schemes for the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) Protocols

    Proposed Standard
  • RFC 6539: IBAKE: Identity-Based Authenticated Key Exchange

    Informational
  • RFC 6506: Supporting Authentication Trailer for OSPFv3

    Proposed Standard

    Obsoleted by RFC 7166

  • RFC 6518: Keying and Authentication for Routing Protocols (KARP) Design Guidelines

    Informational
  • RFC 6394: Use Cases and Requirements for DNS-Based Authentication of Named Entities (DANE)

    Informational
  • RFC 6267: MIKEY-IBAKE: Identity-Based Authenticated Key Exchange (IBAKE) Mode of Key Distribution in Multimedia Internet KEYing (MIKEY)

    Informational
  • RFC 6252: A Framework of Media-Independent Pre-Authentication (MPA) for Inter-Domain Handover Optimization

    Informational
  • RFC 6187: X.509v3 Certificates for Secure Shell Authentication

    Proposed Standard
  • RFC 6091: Using OpenPGP Keys for Transport Layer Security (TLS) Authentication

    Informational
  • RFC 6094: Summary of Cryptographic Authentication Algorithm Implementation Requirements for Routing Protocols

    Informational
  • RFC 6054: Using Counter Modes with Encapsulating Security Payload (ESP) and Authentication Header (AH) to Protect Group Traffic

    Proposed Standard
  • RFC 5925: The TCP Authentication Option

    Proposed Standard
  • RFC 5926: Cryptographic Algorithms for the TCP Authentication Option (TCP-AO)

    Proposed Standard
  • RFC 5776: Use of Timed Efficient Stream Loss-Tolerant Authentication (TESLA) in the Asynchronous Layered Coding (ALC) and NACK-Oriented Reliable Multicast (NORM) Protocols

    Experimental
  • Proposed Standard
  • RFC 5709: OSPFv2 HMAC-SHA Cryptographic Authentication

    Proposed Standard
  • RFC 5310: IS-IS Generic Cryptographic Authentication

    Proposed Standard
  • RFC 5419: Why the Authentication Data Suboption is Needed for Mobile IPv6 (MIPv6)

    Informational
  • RFC 5304: IS-IS Cryptographic Authentication

    Proposed Standard
  • RFC 5169: Handover Key Management and Re-Authentication Problem Statement

    Informational
  • RFC 5155: DNS Security (DNSSEC) Hashed Authenticated Denial of Existence

    Proposed Standard
  • RFC 5083: Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content Type

    Proposed Standard
  • RFC 5054: Using the Secure Remote Password (SRP) Protocol for TLS Authentication

    Informational
  • RFC 5081: Using OpenPGP Keys for Transport Layer Security (TLS) Authentication

    Experimental

    Obsoleted by RFC 6091

  • RFC 4895: Authenticated Chunks for the Stream Control Transmission Protocol (SCTP)

    Proposed Standard
  • RFC 4835: Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard

    Obsoleted by RFC 7321

  • RFC 4822: RIPv2 Cryptographic Authentication

    Proposed Standard
  • RFC 4754: IKE and IKEv2 Authentication Using the Elliptic Curve Digital Signature Algorithm (ECDSA)

    Proposed Standard
  • RFC 4739: Multiple Authentication Exchanges in the Internet Key Exchange (IKEv2) Protocol

    Experimental
  • RFC 4650: HMAC-Authenticated Diffie-Hellman for Multimedia Internet KEYing (MIKEY)

    Proposed Standard
  • RFC 4474: Enhancements for Authenticated Identity Management in the Session Initiation Protocol (SIP)

    Proposed Standard

    Obsoleted by RFC 8224

  • RFC 4552: Authentication/Confidentiality for OSPFv3

    Proposed Standard
  • RFC 4513: Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security Mechanisms

    Proposed Standard
  • RFC 4406: Sender ID: Authenticating E-Mail

    Historic
  • RFC 4478: Repeated Authentication in Internet Key Exchange (IKEv2) Protocol

    Experimental
  • RFC 4442: Bootstrapping Timed Efficient Stream Loss-Tolerant Authentication (TESLA)

    Proposed Standard
  • RFC 4383: The Use of Timed Efficient Stream Loss-Tolerant Authentication (TESLA) in the Secure Real-time Transport Protocol (SRTP)

    Proposed Standard
  • RFC 4359: The Use of RSA/SHA-1 Signatures within Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard
  • RFC 4285: Authentication Protocol for Mobile IPv6

    Informational
  • RFC 4252: The Secure Shell (SSH) Authentication Protocol

    Proposed Standard
  • RFC 4256: Generic Message Exchange Authentication for the Secure Shell Protocol (SSH)

    Proposed Standard
  • RFC 4302: IP Authentication Header

    Proposed Standard
  • RFC 4305: Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)

    Proposed Standard

    Obsoleted by RFC 4835

  • RFC 4169: Hypertext Transfer Protocol (HTTP) Digest Authentication Using Authentication and Key Agreement (AKA) Version-2

    Informational
  • RFC 4082: Timed Efficient Stream Loss-Tolerant Authentication (TESLA): Multicast Source Authentication Transform Introduction

    Informational
  • RFC 4030: The Authentication Suboption for the Dynamic Host Configuration Protocol (DHCP) Relay Agent Option

    Proposed Standard
  • RFC 3893: Session Initiation Protocol (SIP) Authenticated Identity Body (AIB) Format

    Proposed Standard
  • RFC 3655: Redefinition of DNS Authenticated Data (AD) bit

    Proposed Standard

    Obsoleted by RFC 4033, RFC 4034, RFC 4035

  • RFC 3567: Intermediate System to Intermediate System (IS-IS) Cryptographic Authentication

    Informational

    Obsoleted by RFC 5304

  • RFC 3118: Authentication for DHCP Messages

    Proposed Standard
  • RFC 3112: LDAP Authentication Password Schema

    Informational
  • RFC 3097: RSVP Cryptographic Authentication -- Updated Message Type Value

    Proposed Standard
  • RFC 2841: IP Authentication using Keyed SHA1 with Interleaved Padding (IP-MAC)

    Historic
  • RFC 2941: Telnet Authentication Option

    Proposed Standard
  • RFC 2943: TELNET Authentication Using DSA

    Proposed Standard
  • RFC 2944: Telnet Authentication: SRP

    Proposed Standard
  • RFC 2945: The SRP Authentication and Key Exchange System

    Proposed Standard
  • RFC 2951: TELNET Authentication Using KEA and SKIPJACK

    Informational
  • RFC 2829: Authentication Methods for LDAP

    Proposed Standard

    Obsoleted by RFC 4510, RFC 4513

  • RFC 2845: Secret Key Transaction Authentication for DNS (TSIG)

    Proposed Standard

    Obsoleted by RFC 8945

  • RFC 2747: RSVP Cryptographic Authentication

    Proposed Standard
  • RFC 2726: PGP Authentication for RIPE Database Updates

    Proposed Standard
  • RFC 2695: Authentication Mechanisms for ONC RPC

    Informational
  • RFC 2617: HTTP Authentication: Basic and Digest Access Authentication

    Draft Standard

    Obsoleted by RFC 7235, RFC 7615, RFC 7616, RFC 7617

  • RFC 2485: DHCP Option for The Open Group's User Authentication Protocol

    Proposed Standard
  • RFC 2402: IP Authentication Header

    Proposed Standard

    Obsoleted by RFC 4302, RFC 4305

  • RFC 2085: HMAC-MD5 IP Authentication with Replay Prevention

    Proposed Standard
  • RFC 2104: HMAC: Keyed-Hashing for Message Authentication

    Informational
  • RFC 2069: An Extension to HTTP : Digest Access Authentication

    Proposed Standard

    Obsoleted by RFC 2617

  • RFC 2082: RIP-2 MD5 Authentication

    Proposed Standard

    Obsoleted by RFC 4822

  • RFC 1994: PPP Challenge Handshake Authentication Protocol (CHAP)

    Draft Standard
  • RFC 1929: Username/Password Authentication for SOCKS V5

    Proposed Standard
  • RFC 1852: IP Authentication using Keyed SHA

    Experimental

    Obsoleted by RFC 2841

  • RFC 1824: The Exponential Security System TESS: An Identity-Based Cryptographic Protocol for Authenticated Key-Exchange (E.I.S.S.-Report 1995/4)

    Informational
  • RFC 1826: IP Authentication Header

    Proposed Standard

    Obsoleted by RFC 2402

  • RFC 1828: IP Authentication using Keyed MD5

    Historic
  • RFC 1731: IMAP4 Authentication Mechanisms

    Proposed Standard
  • RFC 1734: POP3 AUTHentication command

    Proposed Standard

    Obsoleted by RFC 5034

  • RFC 1416: Telnet Authentication Option

    Experimental

    Obsoleted by RFC 2941

  • RFC 1421: Privacy Enhancement for Internet Electronic Mail: Part I: Message Encryption and Authentication Procedures

    Historic
  • RFC 1409: Telnet Authentication Option

    Experimental

    Obsoleted by RFC 1416

  • RFC 1412: Telnet Authentication: SPX

    Experimental
  • RFC 1334: PPP Authentication Protocols

    Proposed Standard

    Obsoleted by RFC 1994

  • RFC 1113: Privacy enhancement for Internet electronic mail: Part I - message encipherment and authentication procedures

    Historic

    Obsoleted by RFC 1421

  • RFC 1040: Privacy enhancement for Internet electronic mail: Part I: Message encipherment and authentication procedures

    Unknown

    Obsoleted by RFC 1113

  • RFC 1004: Distributed-protocol authentication scheme

    Experimental
  • RFC 989: Privacy enhancement for Internet electronic mail: Part I: Message encipherment and authentication procedures

    Unknown

    Obsoleted by RFC 1040, RFC 1113

  • RFC 912: Authentication service

    Unknown

    Obsoleted by RFC 931

  • RFC 644: On the problem of signature authentication for network mail

    Unknown

Subscribe to authentication

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.