- Home
- RFCs by Subject
- applications
- accessibility
accessibility
Accessibility of Internet communications
Within this page
accessibility RFCs (6)
RFC 9248: Interoperability Profile for Relay User Equipment
Proposed Standard- B. Rosen
- June 2022
- IETF publication
- Applications and Real-Time Area
Abstract
Video Relay Service (VRS) is a term used to describe a method by which a hearing person can communicate with a sign language speaker who is deaf, deafblind, or hard of hearing (HoH) or has a speech disability using an interpreter (i.e., a Communications Assistant (CA)) connected via a videophone to the sign language speaker and an audio telephone call to the hearing user. The CA interprets using sign language on the videophone link and voice on the telephone link. Often the interpreters may be employed by a company or agency, termed a "provider" in this document. The provider also provides a video service that allows users to connect video devices to their service and subsequently to CAs and other sign language speakers. It is desirable that the videophones used by the sign language speaker conform to a standard so that any device may be used with any provider and that direct video calls between sign language speakers work. This document describes the interface between a videophone and a provider.
Abstract
Video Relay Service (VRS) is a term used to describe a method by which a hearing person can communicate with a sign language speaker who is deaf, deafblind, or hard of hearing (HoH) or has a speech disability using an interpreter (i.e., a Communications Assistant (CA)) connected via a videophone to the sign language speaker and an audio telephone call to the hearing user. The CA interprets using sign language on the videophone link and voice on the telephone link. Often the interpreters may be employed by a company or agency, termed a "provider" in this document. The provider also provides a video service that allows users to connect video devices to their service and subsequently to CAs and other sign language speakers. It is desirable that the videophones used by the sign language speaker conform to a standard so that any device may be used with any provider and that direct video calls between sign language speakers work. This document describes the interface between a videophone and a provider.
RFC 5369: Framework for Transcoding with the Session Initiation Protocol (SIP)
Informational- G. Camarillo
- October 2008
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
This document defines a framework for transcoding with SIP. This framework includes how to discover the need for transcoding services in a session and how to invoke those transcoding services. Two models for transcoding services invocation are discussed: the conference bridge model and the third-party call control model. Both models meet the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing, and speech-impaired individuals. This memo provides information for the Internet community.
Abstract
This document defines a framework for transcoding with SIP. This framework includes how to discover the need for transcoding services in a session and how to invoke those transcoding services. Two models for transcoding services invocation are discussed: the conference bridge model and the third-party call control model. Both models meet the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing, and speech-impaired individuals. This memo provides information for the Internet community.
RFC 5370: The Session Initiation Protocol (SIP) Conference Bridge Transcoding Model
Proposed Standard- G. Camarillo
- October 2008
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
This document describes how to invoke transcoding services using the conference bridge model. This way of invocation meets the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing, and speech-impaired individuals. [STANDARDS-TRACK]
Abstract
This document describes how to invoke transcoding services using the conference bridge model. This way of invocation meets the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing, and speech-impaired individuals. [STANDARDS-TRACK]
RFC 5194: Framework for Real-Time Text over IP Using the Session Initiation Protocol (SIP)
Informational- A. van Wijk
- G. Gybels
- June 2008
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
This document lists the essential requirements for real-time Text-over-IP (ToIP) and defines a framework for implementation of all required functions based on the Session Initiation Protocol (SIP) and the Real-Time Transport Protocol (RTP). This includes interworking between Text-over-IP and existing text telephony on the Public Switched Telephone Network (PSTN) and other networks. This memo provides information for the Internet community.
Abstract
This document lists the essential requirements for real-time Text-over-IP (ToIP) and defines a framework for implementation of all required functions based on the Session Initiation Protocol (SIP) and the Real-Time Transport Protocol (RTP). This includes interworking between Text-over-IP and existing text telephony on the Public Switched Telephone Network (PSTN) and other networks. This memo provides information for the Internet community.
RFC 4117: Transcoding Services Invocation in the Session Initiation Protocol (SIP) Using Third Party Call Control (3pcc)
Informational- G. Camarillo
- E. Burger
- H. Schulzrinne
- A. van Wijk
- June 2005
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
This document describes how to invoke transcoding services using Session Initiation Protocol (SIP) and third party call control. This way of invocation meets the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing and speech-impaired individuals. This memo provides information for the Internet community.
Abstract
This document describes how to invoke transcoding services using Session Initiation Protocol (SIP) and third party call control. This way of invocation meets the requirements for SIP regarding transcoding services invocation to support deaf, hard of hearing and speech-impaired individuals. This memo provides information for the Internet community.
RFC 3351: User Requirements for the Session Initiation Protocol (SIP) in Support of Deaf, Hard of Hearing and Speech-impaired Individuals
Informational- N. Charlton
- M. Gasson
- G. Gybels
- M. Spanner
- A. van Wijk
- August 2002
- IETF publication
- Real-time Applications and Infrastructure Area
Abstract
This document aims to present a set of SIP user requirements that
support communications for deaf, hard of hearing and speech-impaired
individuals. These user requirements address the current difficulties
of deaf, hard of hearing and speech-impaired individuals in using
communications facilities, while acknowledging the multi-functional
potential of SIP-based communications.
A number of issues related to these user requirements are further
raised in this document.
Also included are some real world scenarios and some technical
requirements to show the robustness of these requirements on a
concept-level.
Abstract
This document aims to present a set of SIP user requirements that
support communications for deaf, hard of hearing and speech-impaired
individuals. These user requirements address the current difficulties
of deaf, hard of hearing and speech-impaired individuals in using
communications facilities, while acknowledging the multi-functional
potential of SIP-based communications.
A number of issues related to these user requirements are further
raised in this document.
Also included are some real world scenarios and some technical
requirements to show the robustness of these requirements on a
concept-level.
Subscribe to accessibility
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.